VTST version 3.0a compatibility

Vasp transition state theory tools

Moderator: moderators

Post Reply
eduard
Posts: 21
Joined: Tue Sep 02, 2008 1:40 pm

VTST version 3.0a compatibility

Post by eduard »

Dear Graeme,

I have in my group vasp.5.2.2 15Apr09 complex. Is VTST 3.0a compatible with my VASP version ? Or - in order to use VTST 3. 0a - one needs to have Vasp 5.3.x ? If so, which would be the VTST version I should use ?

Wishing you a great day,
Eduard
eduard
Posts: 21
Joined: Tue Sep 02, 2008 1:40 pm

Re: VTST version 3.0a compatibility

Post by eduard »

PS. Same question for the VTST scripts.
graeme
Site Admin
Posts: 1998
Joined: Tue Apr 26, 2005 4:25 am
Contact:

Re: VTST version 3.0a compatibility

Post by graeme »

The latest version of vtstcode and scripts should work with any version of vasp. This is what we aim for, at least. Over time, we will phase out the vasp4 file formats.

We have found only one problem with vasp.5.3.x so far; you can not use a multi-image calculation with KPAR!=1. If you see any other problems, please let us know.
MNPopov
Posts: 4
Joined: Wed Jul 03, 2013 2:31 pm

Re: VTST version 3.0a compatibility

Post by MNPopov »

Dear Graeme,

I've just tried VASP 5.3.3 + VTST 3.0c -- the "KPAR!=1" problem seems to be unresolved so far.
Could we hope to get a fix in the near future?

Best regards,
Maxim.
graeme
Site Admin
Posts: 1998
Joined: Tue Apr 26, 2005 4:25 am
Contact:

Re: VTST version 3.0a compatibility

Post by graeme »

This is due to a bug in vasp, rather than our vtst code. Sam Chill has a fix; you can delete these two lines in main_mpi.F:

IF (KPAR>1.AND.COMM_WORLD%NODE_ME/=COMM_WORLD%IONODE) IO%IU6 = -1
IF (KPAR>1.AND.COMM_WORLD%NODE_ME/=COMM_WORLD%IONODE) IO%IU0 = -1
Post Reply