Page 1 of 1 bug?

Posted: Thu Dec 03, 2020 8:37 pm
by kai
Hi, everyone,

I have been using to prepare my files, and everything went on fine until recently. Simply put, nebmake didnt interpolate good intermediate images any more.

# image 00: POSCAR
0.6205393683339545 0.3748186251700154 0.6113134379103631 T T T
0.4407191996091184 0.3753464715751533 0.6109833865746312 T T T

#image 02: POSCAR
0.6205250119801456 0.8749946587628363 0.6126018270732655 T T T
0.4404841117364926 0.8751503266829158 0.6121692792622382 T T T

But by keying in 00/POSCAR 02/POSCAR 1, i got 01POSCAR as
0.6205321901570500 0.1249066419664260 0.6119576324918160 T T T
0.4406016556728080 0.6252483991290350 0.6115763329184321 T T T

It seems that y values are not correct, but i cannot pinpoint where things went wrong. They are not so close to the edge of the box!
Help! I am using vtst-scripts947

I am attaching the files, and many thanks

Re: bug?

Posted: Fri Dec 04, 2020 8:05 pm
by graeme
The script is working as it should. The issue is that you are moving almost exactly 1/2 way across the box in the y-direction between images 0 and 2. In our script, we find the shortest path between the initial and final states relative to the periodic boundary conditions. For the first atom, it is slightly shorter to go along +y but for the second, it is closer along -y. If you just move the molecule a little closer between the 00 and 02 images, then it will interpolate as you expect it to.

Re: bug?

Posted: Wed Dec 09, 2020 8:12 am
by kai
got it and thanks

Re: bug?

Posted: Sat Jan 23, 2021 4:00 am
by rachita_panigrahi
while i m calculating NEB by using its showing (In, cannot open POSCAR00) can u help me...thanks in advance

Re: bug?

Posted: Thu Jul 01, 2021 7:09 am
by Xingru Tan
I encountered the same problem. When I am trying to use the script nebmake. Error message appears(In, cannot open 'filename'). Can someone please help me?

Re: bug?

Posted: Fri Jul 02, 2021 3:03 am
by Xingru Tan
rachita_panigrahi wrote:
> while i m calculating NEB by using its showing (In
>, cannot open POSCAR00) can u help me...thanks in
> advance

same error solved. Mine is due to typing the wrong dir of the two POSCAR file in the command. Double-check the command.