Problem about compliation of vtstcode v2.4 with vasp 5.2.12

Vasp transition state theory tools

Moderator: moderators

Post Reply
king_jim
Posts: 2
Joined: Mon Sep 05, 2011 7:14 am

Problem about compliation of vtstcode v2.4 with vasp 5.2.12

Post by king_jim »

Recently, I tried to compile the vtstcode 2.4 with vasp 5.2.12. I copied all the *.F files into the vasp source directory, replaced the chain.F file, changed the proper line in main.F file and added the proper .o file into the makefile. The added .F files was compiled successfully, but these errors always occurred:

./preprocess <dynconstr.F | /usr/bin/cpp -P -C -traditional >dynconstr.f90 -DMPI -DHOST=\"LinuxIFC\" -DIFC -Dkind8 -DCACHE_SIZE=12000 -DPGF90 -Davoidalloc -DNGZhalf -DMPI_CHAIN -DMPI_BLOCK=8000 -DRPROMU_DGEMV -DRACCMU_DGEMV
mpiifort -FR -lowercase -assume byterecl -O2 -ip -ftz -c dynconstr.f90
fortcom: Error: dynconstr.f90, line 181: This name does not have a type, and must have an explicit type. [DIR_APP]
OPEN(UNIT=g_io%STRUCTINPUT,FILE=DIR_APP(1:DIR_LEN)//'HILLSPOT',STATUS='REPLACE')
------------------------------------------------^
fortcom: Error: dynconstr.f90, line 181: A substring must be of type CHARACTER. [DIR_APP]
OPEN(UNIT=g_io%STRUCTINPUT,FILE=DIR_APP(1:DIR_LEN)//'HILLSPOT',STATUS='REPLACE')
------------------------------------------------^
fortcom: Error: dynconstr.f90, line 181: This name does not have a type, and must have an explicit type. [DIR_LEN]
OPEN(UNIT=g_io%STRUCTINPUT,FILE=DIR_APP(1:DIR_LEN)//'HILLSPOT',STATUS='REPLACE')
----------------------------------------------------------^
fortcom: Error: dynconstr.f90, line 2181: A substring must be of type CHARACTER. [DIR_APP]
OPEN(UNIT=g_io%STRUCTINPUT,FILE=DIR_APP(1:DIR_LEN)//'HILLSPOT',STATUS='UNKNOWN',POSITION='APPEND')
------------------------------------------^
compilation aborted for dynconstr.f90 (code 1)
make: *** [dynconstr.o] Error 1

The used makefile can compile vasp code without vtstcode successfully.
graeme
Site Admin
Posts: 2037
Joined: Tue Apr 26, 2005 4:25 am
Contact:

Re: Problem about compliation of vtstcode v2.4 with vasp 5.2

Post by graeme »

My understanding is that these errors have been in the vasp code even in earlier versions of vasp 5.2.x and have nothing to do with the vtstcode. The solution, which was mentioned in a previous post here:
viewtopic.php?f=2&t=787&p=2755&hilit=dir_len#p2755
and here:
viewtopic.php?f=2&t=743&p=2544&hilit=dir_len#p2544
is to add the statement
use main_mpi
at the top of the dynconstr.F file.
king_jim
Posts: 2
Joined: Mon Sep 05, 2011 7:14 am

Re: Problem about compliation of vtstcode v2.4 with vasp 5.2

Post by king_jim »

Thank you very much! Now the compilation can be done successfully.
There is another questions about vtstcode. Besides the mentioned .F files in the introduction of installtion, there is another dynamic.F file. When i added the dynamic.o into the source, some syntax error appeared. Is this file needed to compile vtstcode?
graeme
Site Admin
Posts: 2037
Joined: Tue Apr 26, 2005 4:25 am
Contact:

Re: Problem about compliation of vtstcode v2.4 with vasp 5.2

Post by graeme »

Ah, that file is used to run dynamics, but you do not need to compile or link it in. We are going to add some dynamical-based rare event sampling methods into vasp in the future and we will eventually use these routines.
Post Reply