Page 1 of 1

VTST 3.x code updates

Posted: Mon Oct 01, 2012 11:25 pm
by graeme
3.0 (Sept 21, 2012)
- integrate with vasp 5.3.2

3.0a (Oct 1, 2012)
- fixed a bug in which both Bader partitioning and hyperdynamics were given the same ICHAIN index

3.0b (Nov 11, 2012)
- fixed a bug in which chain.F would not build a serial version; thanks to Jiri Polach for reporting the problem

3.0c (Mar 27, 2013)
- changed default sdalpha from 0.1 to 0.02
- removed line in chain.F that was stopping exec of chain and optimizers for images==0

3.0d (Jan 9, 2014)
- fix to EVTOJ declaraction as suggested by Russell Auld
- fix to NEWMODECAR writing as suggested by Craig Plaisance
- more fixes of preprocessor directives

Re: VTST 3.x code updates

Posted: Sun Jan 13, 2013 3:28 am
by christia
I have had trouble getting the VTST tools to work with Vasp version 5.3.3. I have tried it on the TACC Stampede cluster with the Vasp 5.3.3 module loaded, and a dimer test calculation returns the same energy at every ionic step, the atoms do not move. When I changed to the Vasp 4.6 module (without changing anything else), it worked just fine and the results agreed with a previous run on a different system.

I contacted TACC support and they indicated that they compiled both 4.6 and 5.3.3 using the exact same compiler and libraries, and so they believe it may be due to the source code (perhaps the makefile?).

Incidentally, I have used the VTST tools on Kraken which has Vasp 5.3.2, and they work just fine.

I'm not sure if I should contact the Vasp developers instead...please let me know. Also if other information is needed to help diagnose the problem, I would be glad to provide that. Thanks.

Re: VTST 3.x code updates

Posted: Tue Jan 15, 2013 2:52 am
by graeme
Thank you for the post. We'll check into the build on stampede. This machine has been recently upgraded, so there may be some issues to sort out.

Re: VTST 3.x code updates

Posted: Wed Jan 16, 2013 6:59 pm
by graeme
I would be curious if my binaries in ~graeme/bin work for you. They are not built, however, for the phi coprocessors -- if you have any experience doing that, I would be very interested what you find out.

Re: VTST 3.x code updates

Posted: Mon Jan 21, 2013 1:51 pm
by christia
The test dimer run using the vasp binary in ~graeme/bin (linked to vasp.5.3.3_sp02) was successful. The results are in excellent agreement with those I obtained from a compilation on Stampede of vasp5.3.2 with VTST tools. I did notice though that the job took longer, almost twice as long with 5.3.3_sp02 as it did with 5.3.2. The 5.3.2 executable/binary was compiled by TACC staff and placed in my home directory, FYI.

Also, the recent post by michel about Dimer not working sounds very similar to the problems I encountered with the current Stampede compilation of vasp5.3.3.

Re: VTST 3.x code updates

Posted: Mon Jan 21, 2013 3:29 pm
by graeme
Ok, good news. I'll recompile with scalapack, which a student in my group, Sam Chill, has found to be significantly faster. It will be vasp.5.3.3_sp03.

Re: VTST 3.x code updates

Posted: Fri Feb 08, 2013 7:29 pm
by mgsternberg
I'm having difficulties getting the Dimer method to act in VASP-5.3.3 (patched for the DOS bug announced in Jan.) with vtstcode-3.0b-2012-11-11.tar.gz, like christia and michel.

Is there an issue with the source or rather some compiler problem?

I'm using Intel-11.1 compilers, MKL, standalone FFTW, serial or parallel compilation. I tried reducing optimization (-O0 -no-ip), switch to Intel-12.1, but no go. The dimer does not get moved -- there are no ionic updates after the first electronic cycles converges; F does not change in OSZICAR:

N E dE d eps ncg rms rms(c)
DAV: 1 0.223250955825E+03 0.22325E+03 -0.10669E+04 176 0.922E+02
DAV: 2 -0.225989368810E+02 -0.24585E+03 -0.23795E+03 176 0.385E+02
DAV: 3 -0.395761653624E+02 -0.16977E+02 -0.16739E+02 264 0.815E+01
DAV: 4 -0.399525660262E+02 -0.37640E+00 -0.37417E+00 206 0.148E+01
DAV: 5 -0.399640750200E+02 -0.11509E-01 -0.11461E-01 212 0.178E+00 0.814E+00
DAV: 6 -0.384173732706E+02 0.15467E+01 -0.29892E+00 254 0.172E+01 0.334E+00
DAV: 7 -0.383323146097E+02 0.85059E-01 -0.21783E+00 256 0.157E+01 0.321E+00
DAV: 8 -0.380997100038E+02 0.23260E+00 -0.64147E-01 256 0.970E+00 0.422E-01
DAV: 9 -0.380832938933E+02 0.16416E-01 -0.28357E-02 200 0.145E+00 0.184E-01
DAV: 10 -0.380809858649E+02 0.23080E-02 -0.38658E-03 226 0.679E-01 0.120E-01
DAV: 11 -0.380805457963E+02 0.44007E-03 -0.18494E-03 258 0.413E-01 0.676E-02
DAV: 12 -0.380804360097E+02 0.10979E-03 -0.34652E-04 222 0.178E-01 0.138E-02
DAV: 13 -0.380804348035E+02 0.12062E-05 -0.26349E-05 236 0.452E-02 0.743E-03
DAV: 14 -0.380804325879E+02 0.22157E-05 -0.49294E-06 266 0.185E-02 0.419E-03
DAV: 15 -0.380804314188E+02 0.11691E-05 -0.18787E-06 220 0.120E-02 0.134E-03
DAV: 16 -0.380804307357E+02 0.68310E-06 -0.17188E-07 88 0.397E-03 0.722E-04
DAV: 17 -0.380804305238E+02 0.21186E-06 -0.38995E-08 88 0.227E-03 0.231E-04
DAV: 18 -0.380804304787E+02 0.45098E-07 -0.98002E-09 88 0.103E-03
1 F= -.38080430E+02 E0= -.38060876E+02 d E =-.380804E+02
N E dE d eps ncg rms rms(c)
DAV: 1 -0.380804304934E+02 0.30428E-07 -0.23157E-09 88 0.454E-04 0.502E-05
DAV: 2 -0.380804304905E+02 0.29327E-08 -0.16671E-09 88 0.459E-04
2 F= -.38080430E+02 E0= -.38060876E+02 d E =-.117370E-07
N E dE d eps ncg rms rms(c)
DAV: 1 -0.380804304898E+02 0.35743E-08 -0.82963E-10 88 0.330E-04 0.187E-05
DAV: 2 -0.380804304867E+02 0.31614E-08 -0.29075E-10 88 0.113E-04
3 F= -.38080430E+02 E0= -.38060876E+02 d E =0.380305E-08

I believe I installed VTST correctly, having placed all files, patched the Makefile, and main.F; I always do "make clean" before "make".

$ diff -rq ../vasp.5.3 .
Files ../vasp.5.3/Makefile and ./Makefile differ
Only in .: Makefile.orig
Only in .: bbm.F
Only in .: bfgs.F
Only in .: cg.F
Files ../vasp.5.3/chain.F and ./chain.F differ
Only in .: dimer.F
Only in .: dynamic.F
Only in .: dynmat.F
Only in .: fire.F
Only in .: instanton.F
Only in .: lanczos.F
Only in .: lbfgs.F
Files ../vasp.5.3/main.F and ./main.F differ
Only in .: main.F.orig
Only in .: neb.F
Only in .: opt.F
Only in .: qm.F
Only in .: sd.F

$ diff -u ../vasp.5.3/Makefile .
--- ../vasp.5.3/Makefile 2013-01-09 14:56:12.000000000 -0600
+++ ./Makefile 2013-02-08 12:49:23.000000000 -0600
@@ -98,7 +98,9 @@
# the WAVECAR file becomes huge

-FFLAGS = -FR -names lowercase -assume byterecl -i4
+FFLAGS = -FR -names lowercase
+#-assume byterecl

# optimization
@@ -113,7 +115,8 @@

# ifc.9.1, ifc.10.1 recommended
-OFLAG = -O2 -ip
+OFLAG = -O0 -no-ip
+#OFLAG = -O2 -ip

# effectively not used
@@ -214,6 +217,8 @@
paw_base.o metagga.o egrad.o pawsym.o pawfock.o pawlhf.o rhfatm.o hyperfine.o paw.o \
mkpoints_full.o charge.o Lebedev-Laikov.o stockholder.o dipol.o pot.o \
dos.o elf.o tet.o tetweight.o hamil_rot.o \
+ bfgs.o dynmat.o instanton.o lbfgs.o sd.o cg.o dimer.o bbm.o \
+ fire.o lanczos.o neb.o qm.o opt.o \
chain.o dyna.o k-proj.o sphpro.o us.o core_rel.o \
aedens.o wavpre.o wavpre_noio.o broyden.o \
dynbr.o hamil_high.o rmm-diis.o reader.o writer.o tutor.o xml_writer.o \

$ diff -u ../vasp.5.3/main.F .
--- ../vasp.5.3/main.F 2012-12-18 07:29:36.000000000 -0600
+++ ./main.F 2013-02-07 15:53:02.000000000 -0600
@@ -2911,7 +2911,7 @@



Re: VTST 3.x code updates

Posted: Wed Mar 06, 2013 8:48 pm
by hlzya

I am reporting the similar problem mentioned above. The coordinates of atoms do not change during geometry optimization by using the optimizers involved in the VTST code, and there is no output of the script. I am sure the VTST code is involved in the VASP build.

Code: VASP.5.3.3
VTST code: VTST: version 3.0b, (11/11/12).

Any suggestion?

Thank you very much.


Re: VTST 3.x code updates

Posted: Thu Mar 07, 2013 9:49 am
by mrubes
I am having the same issues the optimization does not update a geometry during the run (vasp version 5.3.3 and the lateste VTST tools installed). Any hints where the problem is? Architecture is linux(x86_64) and two different intel compilers tested (ifort 11.0 and ifort 13.0). Small update I am having troubles with new version of VTST version 3.0b, (11/11/12) even in version vasp5.2.12, where the behaviour the same as mentioned above. On the other hand installing vtst(2.04) working fine in vasp5.2.12.

Re: VTST 3.x code updates

Posted: Fri Mar 08, 2013 8:03 pm
by graeme
I'm not sure what might be going wrong here. If you could send .tar.gz files of the complete output directory for one of these runs, it might help to debug the problem.

Re: VTST 3.x code updates

Posted: Fri Mar 08, 2013 10:53 pm
by mrubes
I was just testing the dimer run from your webpages. I don't know what exactly going on, but it seems that even following the instruction on the webpages and no compilation complains the vtst is somehow bypassed and vasp goes to its default optimizaton algorithm (thus when i set ibrion=3 and potim=0, I will be stuck in the same geometry and it will repeatedly yields the same energy). Interestingly this problem is disappears using vtst v.2.04, thus I suspect some problem in chain.F for my compilation set up.

After some testing commenting the followig line in chain.F fixed the problem (it is a section try parallel tempering and VCA code here):
Line(137) IF (images==0) RETURN

any comments?

Re: VTST 3.x code updates

Posted: Sat Mar 09, 2013 2:40 am
by graeme
Sorry about this. There was a difference between what we had in svn and what was posted on the web. I've updated our tar.gz file to a version that should work. As mrubes mention, there was a return function that should have been commented out.